re = /(?=\b((?:\w+ +){2}\w+) +(hello) +((?:\w+ +){0,2}\w+\b))/m
str = 'I am going to say hello and hello to him
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end