package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^1?\s?\(?[0-9]{3}\)?[\-|\s]?[0-9]{3}[\-|\s]?[0-9]{4}$`)
var str = `555-555-5555
5555555555
1 555-555-5555
1 555 555 5555
(555)557-5555
(555) 555-5555
1(555)555-5555`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}