$re = '/^1?\s?\(?[0-9]{3}\)?[\-|\s]?[0-9]{3}[\-|\s]?[0-9]{4}$/m';
$str = '555-555-5555
5555555555
1 555-555-5555
1 555 555 5555
(555)557-5555
(555) 555-5555
1(555)555-5555';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);