import re
regex = re.compile(r"(^[tT][0-9]+[_])(.*)(submit$)", flags=re.MULTILINE)
test_str = ("\n"
"t1_click\n"
"t123_click_submit\n"
"T12_click_click_submit\n"
"t12_click_click_skip\n"
"t1234_click_click_click_skip\n"
"t12_clcik_sdsdssd\n"
"t1234_click_xyz\n"
"T12_click\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")