using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<prefix1>\d{0,3}?)(?<threes1>\d{1,3})\/(?<prefix2>\d{0,3})(?<threes2>\d{3})";
string input = @"1/1
12/1
123/1
1234/1
12345/1
123456/1
1/12
1/123
1/1234
1/12345
1/123456
12/12
123/12
1234/12
12345/12
123456/12
12/123
12/1234
12/12345
12/123456
123/123
1234/123
12345/123
123456/123
123/1234
123/12345
123/123456
1234/1234
12345/1234
123456/1234
1234/12345
1234/123456
12345/12345
123456/12345
12345/123456
123456/123456
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}