import Foundation
let pattern = #"(?<prefix1>\d{0,3}?)(?<threes1>\d{1,3})\/(?<prefix2>\d{0,3})(?<threes2>\d{3})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1/1
12/1
123/1
1234/1
12345/1
123456/1
1/12
1/123
1/1234
1/12345
1/123456
12/12
123/12
1234/12
12345/12
123456/12
12/123
12/1234
12/12345
12/123456
123/123
1234/123
12345/123
123456/123
123/1234
123/12345
123/123456
1234/1234
12345/1234
123456/1234
1234/12345
1234/123456
12345/12345
123456/12345
12345/123456
123456/123456
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)