package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(description|speed|type|peers)\s+set|(classify))`)
var str = `description set
description classify`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}