$re = '/(?:(description|speed|type|peers)\s+set|(classify))/';
$str = 'description set
description classify';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);