package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:https?:\/\/)?([a-zA-Z0-9\.\-_]+)(?:[\/.\-_a-zA-Z0-9]*)$`)
var str = `www.jfkairport.hilton.com/weddings`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}