re = /^(?:https?:\/\/)?([a-zA-Z0-9\.\-_]+)(?:[\/.\-_a-zA-Z0-9]*)$/
str = 'www.jfkairport.hilton.com/weddings'
# Print the match result
str.match(re) do |match|
puts match.to_s
end