package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^A-Za-z'-]`)
var str = `She said - 'That'll be all, Two-Fry.'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}