$re = '/[^A-Za-z\'-]/';
$str = 'She said - \'That\'ll be all, Two-Fry.\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);