import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:TAKE(?: SEL)?\\n)?NAME";
final String string = "NAME V1_LEG-ESP`d=dn`i=1`ns=A#2`ne=A2\n"
+ "VOLPAN 1 0 1 -1\n"
+ "SOFFS 0\n"
+ "PLAYRATE 0.800962 1 0 -1 0 1.234\n"
+ "CHANMODE 6\n"
+ "GUID {8AF5D751-6101-4A4E-A6E2-197036B20A09}\n"
+ "<SOURCE WAVE\n"
+ "FILE \"D:\\Portables\\REAPER\\_TEST PROJECT\\_1\\V1_LEG-ESP`d=dn`i=1`ns=A#2`ne=A2.wav\"\n"
+ ">\n"
+ "SM 1.154427456 1.154427456 0.487179487 + 1.946746472 2.699449536 -0.487179487 + 2.907511262 4.572940878\n"
+ "TAKE\n"
+ "NAME V1_LEG-ESP`d=dn`i=1`ns=A#2`ne=A2\n"
+ "TAKEVOLPAN 0 1 -1\n"
+ "SOFFS 0\n"
+ "PLAYRATE 0.800962 1 0 -1 0 1.234\n"
+ "CHANMODE 6\n"
+ "GUID {BE253668-3738-450B-B8F3-B5FF90E7133C}\n"
+ "<SOURCE WAVE\n"
+ "FILE \"D:\\Portables\\REAPER\\_TEST PROJECT\\_1\\V1_LEG-ESP`d=dn`i=1`ns=A#2`ne=A2.wav\"\n"
+ ">\n"
+ "SM 1.154427456 1.154427456 0.487179487 + 1.946746472 2.699449536 -0.487179487 + 2.907511262 4.572940878\n"
+ "TAKE SEL\n"
+ "NAME V1_LEG-ESP`d=dn`i=1`ns=A#2`ne=A2\n"
+ "TAKEVOLPAN 0 1 -1\n"
+ "SOFFS 0\n"
+ "PLAYRATE 0.800962 1 0 -1 0 1.234\n"
+ "CHANMODE 6\n"
+ "GUID {6F787167-7F7D-4436-8E97-3005F5B12C03}\n"
+ "<SOURCE WAVE\n"
+ "FILE \"D:\\Portables\\REAPER\\_TEST PROJECT\\_1\\V1_LEG-ESP`d=dn`i=1`ns=A#2`ne=A2.wav\"\n"
+ ">\n"
+ "SM 1.154427456 1.154427456 0.487179487 + 1.946746472 2.699449536 -0.487179487 + 2.907511262 4.572940878\n"
+ "TAKE\n"
+ "NAME V1_LEG-ESP`d=dn`i=1`ns=A#2`ne=A2\n"
+ "TAKEVOLPAN 0 1 -1\n"
+ "SOFFS 0\n"
+ "PLAYRATE 0.800962 1 0 -1 0 1.234\n"
+ "CHANMODE 6\n"
+ "GUID {987190C4-B033-4460-ABCA-F5C190AAF4E6}\n"
+ "<SOURCE WAVE\n"
+ "FILE \"D:\\Portables\\REAPER\\_TEST PROJECT\\_1\\V1_LEG-ESP`d=dn`i=1`ns=A#2`ne=A2.wav\"\n"
+ ">\n"
+ "SM 1.154427456 1.154427456 0.487179487 + 1.946746472 2.699449536 -0.487179487 + 2.907511262 4.572940878\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}