const regex = new RegExp('(?:TAKE(?: SEL)?\\n)?NAME', 'sgm')
const str = `NAME V1_LEG-ESP\`d=dn\`i=1\`ns=A#2\`ne=A2
VOLPAN 1 0 1 -1
SOFFS 0
PLAYRATE 0.800962 1 0 -1 0 1.234
CHANMODE 6
GUID {8AF5D751-6101-4A4E-A6E2-197036B20A09}
<SOURCE WAVE
FILE "D:\\Portables\\REAPER\\_TEST PROJECT\\_1\\V1_LEG-ESP\`d=dn\`i=1\`ns=A#2\`ne=A2.wav"
>
SM 1.154427456 1.154427456 0.487179487 + 1.946746472 2.699449536 -0.487179487 + 2.907511262 4.572940878
TAKE
NAME V1_LEG-ESP\`d=dn\`i=1\`ns=A#2\`ne=A2
TAKEVOLPAN 0 1 -1
SOFFS 0
PLAYRATE 0.800962 1 0 -1 0 1.234
CHANMODE 6
GUID {BE253668-3738-450B-B8F3-B5FF90E7133C}
<SOURCE WAVE
FILE "D:\\Portables\\REAPER\\_TEST PROJECT\\_1\\V1_LEG-ESP\`d=dn\`i=1\`ns=A#2\`ne=A2.wav"
>
SM 1.154427456 1.154427456 0.487179487 + 1.946746472 2.699449536 -0.487179487 + 2.907511262 4.572940878
TAKE SEL
NAME V1_LEG-ESP\`d=dn\`i=1\`ns=A#2\`ne=A2
TAKEVOLPAN 0 1 -1
SOFFS 0
PLAYRATE 0.800962 1 0 -1 0 1.234
CHANMODE 6
GUID {6F787167-7F7D-4436-8E97-3005F5B12C03}
<SOURCE WAVE
FILE "D:\\Portables\\REAPER\\_TEST PROJECT\\_1\\V1_LEG-ESP\`d=dn\`i=1\`ns=A#2\`ne=A2.wav"
>
SM 1.154427456 1.154427456 0.487179487 + 1.946746472 2.699449536 -0.487179487 + 2.907511262 4.572940878
TAKE
NAME V1_LEG-ESP\`d=dn\`i=1\`ns=A#2\`ne=A2
TAKEVOLPAN 0 1 -1
SOFFS 0
PLAYRATE 0.800962 1 0 -1 0 1.234
CHANMODE 6
GUID {987190C4-B033-4460-ABCA-F5C190AAF4E6}
<SOURCE WAVE
FILE "D:\\Portables\\REAPER\\_TEST PROJECT\\_1\\V1_LEG-ESP\`d=dn\`i=1\`ns=A#2\`ne=A2.wav"
>
SM 1.154427456 1.154427456 0.487179487 + 1.946746472 2.699449536 -0.487179487 + 2.907511262 4.572940878
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}