package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((([0-9]*\.[0-9]+)|([0-9]+\.[0-9]*))(E(\+|-)?[0-9]+)?)|([0-9]+(E(\+|-)?[0-9]+))`)
var str = `1.123
1.E123
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}