#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)([0-9]{6}\^[0-9]{4})\^#departure time(local time)" & @CRLF & _
"([0-9]{6}\^[0-9]{4})\^#arrival time(local time)" & @CRLF & _
"(\b[A-Z]{3}\b)\^.*?\^(\b[A-Z]{3}\b)#dep and dst airports" & @CRLF & _
"\^.*?\^[A-Z0-9]{2}\^([A-Z0-9]{2}\^\^[0-9]+)#flight number" & @CRLF & _
"\^.*?#" & @CRLF & _
"\^(.?)\^\^#flight class, ex. M=economy class"
Local $sString = "^^010914^1640^020914^0745^MIA^^FRA^1^LH^LH^^463^388^S^M^^LCA^Y^2^^020914^1230^020914^1320^FRA^1^BSL^^LH^CL^^1204^E90^S^M^^LCA^Y^^^^^^^^^^^^^^^^^^^^^1305^LX^3^^120914^1040^120914^1156^ZDH^^ZRH^^LX^LX^^7409^TRN^S^M^^LCA^Y^4^^120914^1320^120914^1745^ZRH^^MIA^^LX^LX^^64^333^S^M^^LCA^Y^^^^^^^^^^^^^^^^^^^^^"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")