import re
regex = re.compile(r"""
([0-9]{6}\^[0-9]{4})\^#departure time(local time)
([0-9]{6}\^[0-9]{4})\^#arrival time(local time)
(\b[A-Z]{3}\b)\^.*?\^(\b[A-Z]{3}\b)#dep and dst airports
\^.*?\^[A-Z0-9]{2}\^([A-Z0-9]{2}\^\^[0-9]+)#flight number
\^.*?#
\^(.?)\^\^#flight class, ex. M=economy class
""", flags=re.VERBOSE)
test_str = "^^010914^1640^020914^0745^MIA^^FRA^1^LH^LH^^463^388^S^M^^LCA^Y^2^^020914^1230^020914^1320^FRA^1^BSL^^LH^CL^^1204^E90^S^M^^LCA^Y^^^^^^^^^^^^^^^^^^^^^1305^LX^3^^120914^1040^120914^1156^ZDH^^ZRH^^LX^LX^^7409^TRN^S^M^^LCA^Y^4^^120914^1320^120914^1745^ZRH^^MIA^^LX^LX^^64^333^S^M^^LCA^Y^^^^^^^^^^^^^^^^^^^^^"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")