#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:8[ -]?\d{2}[ -]?\d{2}(?:[ -]?\d{2})?|\+\d{3}[ -]?\d{3}[ -]?\d{3})$"
Local $sString = "+375111111" & @CRLF & _
"+375 111 111" & @CRLF & _
"+375-111-111" & @CRLF & _
"8111111" & @CRLF & _
"8 11 11" & @CRLF & _
"8-11-11"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")