$re = '/^(?:8[ -]?\d{2}[ -]?\d{2}(?:[ -]?\d{2})?|\+\d{3}[ -]?\d{3}[ -]?\d{3})$/m';
$str = '+375111111
+375 111 111
+375-111-111
8111111
8 11 11
8-11-11';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);