// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(\S[^\.]*)(\.(\S*))?@(\S*)").unwrap();
let string = "jim.beam@no.com
jim@no.com
jo-ei@jim.beam
gu@stav-to.cc
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}