using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ZhuiShuShenQi\/\d+(?:(\.\d+)+)";
string input = @"ZhuiShuShenQi/3.42.123";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}