package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`ZhuiShuShenQi\/\d+(?:(\.\d+)+)`)
var str = `ZhuiShuShenQi/3.42.123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}