$re = '/^(?:- *)?\K[^*\n]+?(?= ::)/m';
$str = 'question :: answer # should match \'question\'
question ::answer # should match \' question\'
**question** :: answer # should not match
*question* :: answer # should not match
- question :: answer # should only match \'question\' and not \'- question\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);