re = /^(?:- *)?\K[^*\n]+?(?= ::)/m
str = 'question :: answer # should match \'question\'
question ::answer # should match \' question\'
**question** :: answer # should not match
*question* :: answer # should not match
- question :: answer # should only match \'question\' and not \'- question\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end