$re = '/(a|c|b[^c])+/m';
$str = 'abc
acb
bac
bca
cab
cba
cabcabcbacbcaaaccbbaaccacbac';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);