re = /(a|c|b[^c])+/m
str = 'abc
acb
bac
bca
cab
cba
cabcabcbacbcaaaccbbaaccacbac'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end