re = /^P(([0-9]+Y)?([0-9]+M)?([0-9]+W)?([0-9]+D)?(T([0-9]+H)?([0-9]+M)?([0-9]+(\.?[0-9]+)?S)?))?$/
str = '^P(([0-9]+Y)?([0-9]+M)?([0-9]+W)?([0-9]+D)?)?(T(([0-9]+)H)?(([0-9]+)M)?(([0-9]+\\.?[0-9]*)S)?)?$'
# Print the match result
str.match(re) do |match|
puts match.to_s
end