using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*(lr_start_transaction.*\))\s*;\s*$";
string substitution = @"\1\);";
string input = @"lr_start_transaction(lr_eval_string(""{scriptid}_0070_00000000_ASP-Hinzufuegen"");
Siebel_SWECount_var -= 3;
lr_save_int(Siebel_SWECount_var, ""Siebel_SWECount"");
web_save_timestamp_param(""SiebelTimeStamp"",
LAST);
web_add_cookie(""SWEUAID=6; DOMAIN={domain}"");
web_url(""start.swe_60"",
""URL={url_start}?SWECmd=ShowPopupFrames&SWEDIC=1&SWEU={url_start}%3fSWECmd%3dGetCachedFrame%26SWEC%3d47%26SWEFrame%3dtop._sweclient._swecontent._sweview._swetmp%26SRN%3d{Siebel_SRN10}%26SWESP%3d1%26SRN%3d{Siebel_SRN10}&SRN={Siebel_SRN10}"",
""TargetFrame="",
""Resource=0"",
""RecContentType=text/html"",
""Referer="",
""Snapshot=t587.inf"",
""Mode=HTML"",
LAST);
lr_end_transaction(lr_eval_string(""{scriptid}_0070_00000000_ASP-Hinzufuegen""),LR_AUTO);
lr_think_time(iThinktime);
lr_start_transaction(lr_eval_string(""{scriptid}_0080_00000000_ASP-Hinzufuegen-Eingabe"");
Siebel_SWECount_var += 4;
lr_save_int(Siebel_SWECount_var, ""Siebel_SWECount"");
web_reg_find(""Text=Error"",""Search=Body"", ""Fail=Found"", LAST);
web_submit_data(""start.swe_61"",
""Action={url_start}"",
""Method=POST"",
""TargetFrame="",
""RecContentType=text/html"",
""Referer="",
""Snapshot=t588.inf"",
""Mode=HTML"",
""EncodeAtSign=YES"",
ITEMDATA,
""Name=SWEC"", ""Value={Siebel_SWECount}"", ENDITEM,
""Name=SWEMethod"", ""Value=UpdatePrefMsg"", ENDITEM,
""Name=SWERPC"", ""Value=1"", ENDITEM,
""Name=SWECmd"", ""Value=InvokeMethod"", ENDITEM,
""Name=SRN"", ""Value={Siebel_SRN10}"", ENDITEM,
""Name=SWEIPS"", ""Value=@0*0*1*0*0*3*0*5*SWEBS1*1"", ENDITEM,
""Name=SWEBS"", ""Value=1"", ENDITEM,
""Name=SWEService"", ""Value=Message Bar"", ENDITEM,
LAST); ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}