# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*(lr_start_transaction.*\))\s*;\s*$"
test_str = ("lr_start_transaction(lr_eval_string(\"{scriptid}_0070_00000000_ASP-Hinzufuegen\");\n\n"
"Siebel_SWECount_var -= 3;\n\n"
"lr_save_int(Siebel_SWECount_var, \"Siebel_SWECount\");\n\n"
"web_save_timestamp_param(\"SiebelTimeStamp\", \n"
" LAST);\n\n"
"web_add_cookie(\"SWEUAID=6; DOMAIN={domain}\");\n\n"
"web_url(\"start.swe_60\", \n"
" \"URL={url_start}?SWECmd=ShowPopupFrames&SWEDIC=1&SWEU={url_start}%3fSWECmd%3dGetCachedFrame%26SWEC%3d47%26SWEFrame%3dtop._sweclient._swecontent._sweview._swetmp%26SRN%3d{Siebel_SRN10}%26SWESP%3d1%26SRN%3d{Siebel_SRN10}&SRN={Siebel_SRN10}\", \n"
" \"TargetFrame=\", \n"
" \"Resource=0\", \n"
" \"RecContentType=text/html\", \n"
" \"Referer=\", \n"
" \"Snapshot=t587.inf\", \n"
" \"Mode=HTML\", \n"
" LAST);\n\n"
"lr_end_transaction(lr_eval_string(\"{scriptid}_0070_00000000_ASP-Hinzufuegen\"),LR_AUTO); \n\n"
"lr_think_time(iThinktime);\n\n"
"lr_start_transaction(lr_eval_string(\"{scriptid}_0080_00000000_ASP-Hinzufuegen-Eingabe\");\n\n"
"Siebel_SWECount_var += 4;\n\n"
"lr_save_int(Siebel_SWECount_var, \"Siebel_SWECount\");\n\n"
"web_reg_find(\"Text=Error\",\"Search=Body\", \"Fail=Found\", LAST);\n\n"
"web_submit_data(\"start.swe_61\", \n"
" \"Action={url_start}\", \n"
" \"Method=POST\", \n"
" \"TargetFrame=\", \n"
" \"RecContentType=text/html\", \n"
" \"Referer=\", \n"
" \"Snapshot=t588.inf\", \n"
" \"Mode=HTML\", \n"
" \"EncodeAtSign=YES\", \n"
" ITEMDATA, \n"
" \"Name=SWEC\", \"Value={Siebel_SWECount}\", ENDITEM, \n"
" \"Name=SWEMethod\", \"Value=UpdatePrefMsg\", ENDITEM, \n"
" \"Name=SWERPC\", \"Value=1\", ENDITEM, \n"
" \"Name=SWECmd\", \"Value=InvokeMethod\", ENDITEM, \n"
" \"Name=SRN\", \"Value={Siebel_SRN10}\", ENDITEM, \n"
" \"Name=SWEIPS\", \"Value=@0*0*1*0*0*3*0*5*SWEBS1*1\", ENDITEM, \n"
" \"Name=SWEBS\", \"Value=1\", ENDITEM, \n"
" \"Name=SWEService\", \"Value=Message Bar\", ENDITEM, \n"
" LAST); ")
subst = "\\1\\);"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.