$re = '/(?:\/[^\/]+){2}(.*)/';
$str = '/skukke/integration/build/IO/something';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);