const regex = /(?<=join)\s*(\w+)(?=.*on)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=join)\\s*(\\w+)(?=.*on)', '')
const str = `left outer join Employee e on p.employee_id = e.employee_id `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}