$re = '/(?<=join)\s*(\w+)(?=.*on)/';
$str = 'left outer join Employee e on p.employee_id = e.employee_id ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);