$re = '/(?<=join\s)\s*\K(\w+)\b(?=.*on)/';
$str = 'left outer join course c on s.id = c.id';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);