re = /(?<=join\s)\s*\K(\w+)\b(?=.*on)/
str = 'left outer join course c on s.id = c.id'
# Print the match result
str.match(re) do |match|
puts match.to_s
end