re = /(\d) x (.+?): RM(\d+\.\d)/
str = '2 x Brew Coffeee Panas: RM7.42 x Tongkat Ali Ais: RM8.6'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end