// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d) x (.+?): RM(\d+\.\d)").unwrap();
let string = "2 x Brew Coffeee Panas: RM7.42 x Tongkat Ali Ais: RM8.6";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}