using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^/[A-Z]{3}-NN_";
string input = @"AB CC - YY172SO - Water pump parts
XX- MC172-99CC - Gas pump parts
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}