$re = '~^/[A-Z]{3}-NN_~im';
$str = 'AB CC - YY172SO - Water pump parts
XX- MC172-99CC - Gas pump parts
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);