const regex = /^[0-9A-F]{2}[:\- ]{5}[0-9A-F]{2}$/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9A-F]{2}[:\\- ]{5}[0-9A-F]{2}$', 'm')
const str = `77:- -AB
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}