$re = '/^[0-9A-F]{2}[:\- ]{5}[0-9A-F]{2}$/m';
$str = '77:- -AB
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);