re = /^admin[a-z]+(?!ex)$/im
str = 'adminUpdate
adminDeleteEx
adminEditXe
adminExclude
listWebsite
listEx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end