using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"=([A-Za-z0-9]+)";
string input = @"CN=TEST,OU=Servers,DC=sibmg,DC=local";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}