const regex = /([\S\s]+) 发表于 \d+\-\d+-\d+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\S\\s]+) 发表于 \\d+\\-\\d+-\\d+', '')
const str = ` #ad \$~min ~ 发表于 2015-4-23 09:42`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}