import re
regex = re.compile(r"([\S\s]+) 发表于 \d+\-\d+-\d+")
test_str = " #ad $~min ~ 发表于 2015-4-23 09:42"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")