using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\{|,)\""(?!slug).*?\""";
string substitution = @"";
string input = @"[{""id"":""0"",""title"":""Testowy post Laravela"",""subtitle"":"",""author"":""Marcin"",""content"":""Tekst nr 4"",""slug"":""testowy-post-laravela-4"",""created_at"":""2014-11-02 10:30:42"",""updated_at"":""2014-11-02 10:30:42""},{""id"":""1"",""title"":""Testowy post Laravela"",""subtitle"":"",""author"":""Marcin"",""content"":""Tekst nr 0"",""slug"":""testowy-post-laravela-0"",""created_at"":""2014-11-02 10:30:42"",""updated_at"":""2014-11-02 10:30:42""},{""id"":""2"",""title"":""Testowy post Laravela"",""subtitle"":""It's a rocket!"",""author"":""Marcin"",""content"":""Tekst nr 1"",""slug"":""testowy-post-laravela-1"",""created_at"":""2014-11-02 10:30:42"",""updated_at"":""2014-11-02 10:30:42""},{""id"":""3"",""title"":""Testowy post Laravela"",""subtitle"":"",""author"":""Marcin"",""content"":""Tekst nr 2"",""slug"":""testowy-post-laravela-2"",""created_at"":""2014-11-02 10:30:42"",""updated_at"":""2014-11-02 10:30:42""},{""id"":""19"",""title"":""Testowy post Laravela"",""subtitle"":"",""author"":""Marcin"",""content"":""Tekst nr 3"",""slug"":""testowy-post-laravela-3"",""created_at"":""2014-11-02 10:30:42"",""updated_at"":""2014-11-02 10:30:42""}]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}