import Foundation
let pattern = #"(\{|,)\"(?!slug).*?\""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"[{"id":"0","title":"Testowy post Laravela","subtitle":"","author":"Marcin","content":"Tekst nr 4","slug":"testowy-post-laravela-4","created_at":"2014-11-02 10:30:42","updated_at":"2014-11-02 10:30:42"},{"id":"1","title":"Testowy post Laravela","subtitle":"","author":"Marcin","content":"Tekst nr 0","slug":"testowy-post-laravela-0","created_at":"2014-11-02 10:30:42","updated_at":"2014-11-02 10:30:42"},{"id":"2","title":"Testowy post Laravela","subtitle":"It's a rocket!","author":"Marcin","content":"Tekst nr 1","slug":"testowy-post-laravela-1","created_at":"2014-11-02 10:30:42","updated_at":"2014-11-02 10:30:42"},{"id":"3","title":"Testowy post Laravela","subtitle":"","author":"Marcin","content":"Tekst nr 2","slug":"testowy-post-laravela-2","created_at":"2014-11-02 10:30:42","updated_at":"2014-11-02 10:30:42"},{"id":"19","title":"Testowy post Laravela","subtitle":"","author":"Marcin","content":"Tekst nr 3","slug":"testowy-post-laravela-3","created_at":"2014-11-02 10:30:42","updated_at":"2014-11-02 10:30:42"}]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)