package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w+$`)
var str = `correct
foobar
foo bar
bar-foo
foo.bar
noway, sir
definitelynot
unicodeæøå`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}