#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^+0-9\n]+[^(?:\s+0-9)*]"
Local $sString = "๐ฆ๐ซ Afghanistan +93" & @CRLF & _
"๐ฆ๐ฝ ร
land Islands +358" & @CRLF & _
"๐ฆ๐ฑ Albania +355" & @CRLF & _
"๐ฉ๐ฟ Algeria +213" & @CRLF & _
"๐ฆ๐ธ American Samoa +1684" & @CRLF & _
"๐ฆ๐ฉ Andorra +376" & @CRLF & _
"๐ฆ๐ด Angola +244" & @CRLF & _
"๐ฆ๐ฎ Anguilla +1264" & @CRLF & _
"๐ฆ๐ฌ Antigua & Barbuda +1268" & @CRLF & _
"๐ฆ๐ท Argentina +54" & @CRLF & _
"๐ฆ๐ฒ Armenia +374" & @CRLF & _
"๐ฆ๐ผ Aruba +297" & @CRLF & _
"๐ฆ๐บ Australia +61" & @CRLF & _
"๐ฆ๐น Austria +43" & @CRLF & _
"๐ฆ๐ฟ Azerbaijan +994" & @CRLF & _
"๐ง๐ธ Bahamas +1242" & @CRLF & _
"๐ง๐ญ Bahrain +973" & @CRLF & _
"๐ง๐ฉ Bangladesh +880" & @CRLF & _
"๐ง๐ง Barbados +1246" & @CRLF & _
"๐ง๐พ Belarus +375" & @CRLF & _
"๐ง๐ช Belgium +32" & @CRLF & _
"๐ง๐ฟ Belize +501" & @CRLF & _
"๐ง๐ฏ Benin +229" & @CRLF & _
"๐ง๐ฒ Bermuda +1441" & @CRLF & _
"๐ง๐น Bhutan +975" & @CRLF & _
"๐ง๐ด Bolivia +591" & @CRLF & _
"๐ง๐ฆ Bosnia & Herzegovina +387" & @CRLF & _
"๐ง๐ผ Botswana +267" & @CRLF & _
"๐ง๐ท Brazil +55" & @CRLF & _
"๐ฎ๐ด British Indian Ocean Territory +246" & @CRLF & _
"๐ป๐ฌ British Virgin Islands +1284" & @CRLF & _
"๐ง๐ณ Brunei +673" & @CRLF & _
"๐ง๐ฌ Bulgaria +359" & @CRLF & _
"๐ง๐ซ Burkina Faso +226" & @CRLF & _
"๐ง๐ฎ Burundi +257" & @CRLF & _
"๐ฐ๐ญ Cambodia +855" & @CRLF & _
"๐จ๐ฒ Cameroon +237" & @CRLF & _
"๐จ๐ฆ Canada +1" & @CRLF & _
"๐จ๐ป Cape Verde +238" & @CRLF & _
"๐ณ๐ฑ Carribbean Netherlands +599" & @CRLF & _
"๐ฐ๐พ Cayman Islands +1345" & @CRLF & _
"๐จ๐ซ Central African Republic +236" & @CRLF & _
"๐น๐ฉ Chad +235" & @CRLF & _
"๐จ๐ฑ Chile +56" & @CRLF & _
"๐จ๐ณ China +86" & @CRLF & _
"๐จ๐ฝ Christmas Islands +61" & @CRLF & _
"๐จ๐จ Cocos Islands +61" & @CRLF & _
"๐จ๐ด Colombia +57" & @CRLF & _
"๐ฐ๐ฒ Comoros +269" & @CRLF & _
"๐จ๐ฉ Congo-Kinshasa +243" & @CRLF & _
"๐จ๐ฌ Congo-Brazzaville +242" & @CRLF & _
"๐จ๐ฐ Cook Islands +682" & @CRLF & _
"๐จ๐ท Costa Rica +506" & @CRLF & _
"๐ญ๐ท Croatia +385" & @CRLF & _
"๐จ๐บ Cuba +53" & @CRLF & _
"๐จ๐ผ Curaรงao +599" & @CRLF & _
"๐จ๐พ Cyprus +357" & @CRLF & _
"๐จ๐ฟ Czechia +420" & @CRLF & _
"๐ฉ๐ฐ Denmark +45" & @CRLF & _
"๐ฉ๐ฏ Djibouti +253" & @CRLF & _
"๐ฉ๐ฒ Dominica +1767" & @CRLF & _
"๐ฉ๐ด Dominican Republic +1" & @CRLF & _
"๐ช๐จ Ecuador +593" & @CRLF & _
"๐ช๐ฌ Egypt +20" & @CRLF & _
"๐ธ๐ป El Salvador +503" & @CRLF & _
"๐ฌ๐ถ Equatorial Guinea +240" & @CRLF & _
"๐ช๐ท Eritrea +291" & @CRLF & _
"๐ช๐ช Estonia +372" & @CRLF & _
"๐ช๐น Ethiopia +251" & @CRLF & _
"๐ซ๐ฐ Falkland Islands +500" & @CRLF & _
"๐ซ๐ด Faroe Islands +298" & @CRLF & _
"๐ซ๐ฏ Fiji +679" & @CRLF & _
"๐ซ๐ฎ Finland +358" & @CRLF & _
"๐ซ๐ท France +33" & @CRLF & _
"๐ฌ๐ซ French Guiana +594" & @CRLF & _
"๐ต๐ซ French Polynesia +689" & @CRLF & _
"๐ฌ๐ฆ Gabon +241" & @CRLF & _
"๐ฌ๐ฒ Gambia +220" & @CRLF & _
"๐ฌ๐ช Georgia +995" & @CRLF & _
"๐ฉ๐ช Germany +49" & @CRLF & _
"๐ฌ๐ญ Ghana +233" & @CRLF & _
"๐ฌ๐ฎ Gibraltar +350" & @CRLF & _
"๐ฌ๐ท Greece +30" & @CRLF & _
"๐ฌ๐ฑ Greenland +299" & @CRLF & _
"๐ฌ๐ฉ Grenada +1473" & @CRLF & _
"๐ฌ๐ต Guadeloupe +590" & @CRLF & _
"๐ฌ๐บ Guam +1671" & @CRLF & _
"๐ฌ๐น Guatemala +502" & @CRLF & _
"๐ฌ๐ฌ Guernsey +44" & @CRLF & _
"๐ฌ๐ณ Guinea +224" & @CRLF & _
"๐ฌ๐ผ Guinea-Bissau +245" & @CRLF & _
"๐ฌ๐พ Guyana +592" & @CRLF & _
"๐ญ๐น Haiti +509" & @CRLF & _
"๐ญ๐ณ Honduras +504" & @CRLF & _
"๐ญ๐ฐ Hong Kong +852" & @CRLF & _
"๐ญ๐บ Hungary +36" & @CRLF & _
"๐ฎ๐ธ Iceland +354" & @CRLF & _
"๐ฎ๐ณ India +91" & @CRLF & _
"๐ฎ๐ฉ Indonesia +62" & @CRLF & _
"๐ฎ๐ท Iran +98" & @CRLF & _
"๐ฎ๐ถ Iraq +964" & @CRLF & _
"๐ฎ๐ช Ireland +353" & @CRLF & _
"๐ฎ๐ฒ Isle of Man +44" & @CRLF & _
"๐ฎ๐ฑ Israel +972" & @CRLF & _
"๐ฎ๐น Italy +39" & @CRLF & _
"๐จ๐ฎ Ivory Coast +225" & @CRLF & _
"๐ฏ๐ฒ Jamaica +1" & @CRLF & _
"๐ฏ๐ต Japan +81" & @CRLF & _
"๐ฏ๐ช Jersey +44" & @CRLF & _
"๐ฏ๐ด Jordan +962" & @CRLF & _
"๐ฐ๐ฟ Kazakhstan +7" & @CRLF & _
"๐ฐ๐ช Kenya +254" & @CRLF & _
"๐ฐ๐ฎ Kiribati +686" & @CRLF & _
"๐ฝ๐ฐ Kosovo +383" & @CRLF & _
"๐ฐ๐ผ Kuwait +965" & @CRLF & _
"๐ฐ๐ฌ Kyrgyzstan +996" & @CRLF & _
"๐ฑ๐ฆ Laos +856" & @CRLF & _
"๐ฑ๐ป Latvia +371" & @CRLF & _
"๐ฑ๐ง Lebanon +961" & @CRLF & _
"๐ฑ๐ธ Lesotho +266" & @CRLF & _
"๐ฑ๐ท Liberia +231" & @CRLF & _
"๐ฑ๐พ Libya +218" & @CRLF & _
"๐ฑ๐ฎ Liechtenstein +423" & @CRLF & _
"๐ฑ๐น Lithuania +370" & @CRLF & _
"๐ฑ๐บ Luxembourg +352" & @CRLF & _
"๐ฒ๐ด Macau +853" & @CRLF & _
"๐ฒ๐ฌ Madagascar +261" & @CRLF & _
"๐ฒ๐ผ Malawi +265" & @CRLF & _
"๐ฒ๐พ Malaysia +60" & @CRLF & _
"๐ฒ๐ป Maldives +960" & @CRLF & _
"๐ฒ๐ฑ Mali +223" & @CRLF & _
"๐ฒ๐น Malta +356" & @CRLF & _
"๐ฒ๐ญ Marshall Islands +692" & @CRLF & _
"๐ฒ๐ถ Martinique +596" & @CRLF & _
"๐ฒ๐ท Mauritania +222" & @CRLF & _
"๐ฒ๐บ Mauritius +230" & @CRLF & _
"๐พ๐น Mayotte +262" & @CRLF & _
"๐ฒ๐ฝ Mexico +52" & @CRLF & _
"๐ซ๐ฒ Micronesia +691" & @CRLF & _
"๐ฒ๐ฉ Moldova +373" & @CRLF & _
"๐ฒ๐จ Monaco +377" & @CRLF & _
"๐ฒ๐ณ Mongolia +976" & @CRLF & _
"๐ฒ๐ช Montenegro +382" & @CRLF & _
"๐ฒ๐ธ Montserrat +1664" & @CRLF & _
"๐ฒ๐ฆ Morocco +212" & @CRLF & _
"๐ฒ๐ฟ Mozambique +258" & @CRLF & _
"๐ฒ๐ฒ Myanmar +95" & @CRLF & _
"๐ณ๐ฆ Namibia +264" & @CRLF & _
"๐ณ๐ท Nauru +674" & @CRLF & _
"๐ณ๐ต Nepal +977" & @CRLF & _
"๐ณ๐ฑ Netherlands +31" & @CRLF & _
"๐ณ๐จ New Caledonia +687" & @CRLF & _
"๐ณ๐ฟ New Zealand +64" & @CRLF & _
"๐ณ๐ฎ Nicaragua +505" & @CRLF & _
"๐ณ๐ช Niger +227" & @CRLF & _
"๐ณ๐ฌ Nigeria +234" & @CRLF & _
"๐ณ๐บ Niue +683" & @CRLF & _
"๐ณ๐ซ Norfolk Island +6723" & @CRLF & _
"๐ฐ๐ต North Korea +850" & @CRLF & _
"๐ฒ๐ฐ North Macedonia +389" & @CRLF & _
"๐ฒ๐ต Northern Mariana Islands +1670" & @CRLF & _
"๐ณ๐ด Norway +47" & @CRLF & _
"๐ด๐ฒ Oman +968" & @CRLF & _
"๐ต๐ฐ Pakistan +92" & @CRLF & _
"๐ต๐ผ Palau +680" & @CRLF & _
"๐ต๐ฆ Panama +507" & @CRLF & _
"๐ต๐ฌ Papua New Guinea +675" & @CRLF & _
"๐ต๐พ Paraguay +595" & @CRLF & _
"๐ต๐ช Peru +51" & @CRLF & _
"๐ต๐ญ Philippines +63" & @CRLF & _
"๐ต๐ฑ Poland +48" & @CRLF & _
"๐ต๐น Portugal +351" & @CRLF & _
"๐ต๐ท Puerto Rico +1" & @CRLF & _
"๐ถ๐ฆ Qatar +974" & @CRLF & _
"๐ซ๐ท Rรฉunion +262" & @CRLF & _
"๐ท๐ด Romania +40" & @CRLF & _
"๐ท๐บ Russia +7" & @CRLF & _
"๐ท๐ผ Rwanda +250" & @CRLF & _
"๐ง๐ฑ Saint-Barthรฉlemy +590" & @CRLF & _
"๐ธ๐ญ Saint Helena +290" & @CRLF & _
"๐ฐ๐ณ Saint Kitts & Nevis +1869" & @CRLF & _
"๐ฑ๐จ Saint Lucia +1758" & @CRLF & _
"๐ซ๐ท Saint Martin +590" & @CRLF & _
"๐ต๐ฒ Saint Pierre & Miquelon +508" & @CRLF & _
"๐ป๐จ Saint Vincent & Grenadines +1784" & @CRLF & _
"๐ผ๐ธ Samoa +685" & @CRLF & _
"๐ธ๐ฒ San Marino +378" & @CRLF & _
"๐ธ๐น Sรฃo Tomรฉ & Prรญncipe +239" & @CRLF & _
"๐ธ๐ฆ Saudi Arabia +966" & @CRLF & _
"๐ธ๐ณ Senegal +221" & @CRLF & _
"๐ท๐ธ Serbia +381" & @CRLF & _
"๐ธ๐จ Seychelles +248" & @CRLF & _
"๐ธ๐ฑ Sierra Leone +232" & @CRLF & _
"๐ธ๐ฌ Singapore +65" & @CRLF & _
"๐ธ๐ฝ Sint Maarten +1721" & @CRLF & _
"๐ธ๐ฐ Slovakia +421" & @CRLF & _
"๐ธ๐ฎ Slovenia +386" & @CRLF & _
"๐ธ๐ง Solomon Islands +677" & @CRLF & _
"๐ธ๐ด Somalia +252" & @CRLF & _
"๐ฟ๐ฆ South Africa +27" & @CRLF & _
"๐ฐ๐ท South Korea +82" & @CRLF & _
"๐ธ๐ธ South Sudan +211" & @CRLF & _
"๐ช๐ธ Spain +34" & @CRLF & _
"๐ฑ๐ฐ Sri Lanka +94" & @CRLF & _
"๐ธ๐ฉ Sudan +249" & @CRLF & _
"๐ธ๐ท Suriname +597" & @CRLF & _
"๐ณ๐ด Svalbard & Jan Mayen +47" & @CRLF & _
"๐ธ๐ฟ Swaziland +268" & @CRLF & _
"๐ธ๐ช Sweden +46" & @CRLF & _
"๐จ๐ญ Switzerland +41" & @CRLF & _
"๐ธ๐พ Syria +963" & @CRLF & _
"๐น๐ผ Taiwan +886" & @CRLF & _
"๐น๐ฏ Tajikistan +992" & @CRLF & _
"๐น๐ฟ Tanzania +255" & @CRLF & _
"๐น๐ญ Thailand +66" & @CRLF & _
"๐น๐ฑ Timor-Leste +670" & @CRLF & _
"๐น๐ฌ Togo +228" & @CRLF & _
"๐น๐ฐ Tokelau +690" & @CRLF & _
"๐น๐ด Tonga +676" & @CRLF & _
"๐น๐น Trinidad & Tobago +1868" & @CRLF & _
"๐น๐ณ Tunisia +216" & @CRLF & _
"๐น๐ท Turkey +90" & @CRLF & _
"๐น๐ฒ Turkmenistan +993" & @CRLF & _
"๐น๐จ Turks & Caicos Islands +1649" & @CRLF & _
"๐น๐ป Tuvalu +688" & @CRLF & _
"๐ป๐ฎ U.S. Virgin Islands +1340" & @CRLF & _
"๐บ๐ฌ Uganda +256" & @CRLF & _
"๐บ๐ฆ Ukraine +380" & @CRLF & _
"๐ฆ๐ช United Arab Emirates +971" & @CRLF & _
"๐ฌ๐ง United Kingdom +44" & @CRLF & _
"๐บ๐ธ United States +1" & @CRLF & _
"๐บ๐พ Uruguay +598" & @CRLF & _
"๐บ๐ฟ Uzbekistan +998" & @CRLF & _
"๐ป๐บ Vanuatu +678" & @CRLF & _
"๐ป๐ฆ Vatican City +39" & @CRLF & _
"๐ป๐ช Venezuela +58" & @CRLF & _
"๐ป๐ณ Vietnam +84" & @CRLF & _
"๐ผ๐ซ Wallis & Futuna +681" & @CRLF & _
"๐ช๐ญ Western Sahara +212" & @CRLF & _
"๐พ๐ช Yemen +967" & @CRLF & _
"๐ฟ๐ฒ Zambia +260" & @CRLF & _
"๐ฟ๐ผ Zimbabwe +263"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")