#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=[a-zA-Z]),(?=[a-zA-Z\s])"
Local $sString = "2015,1674,240/09,PEOPLE V. MICHAEL JORDAN,15,15" & @CRLF & _
"2015,2135,602832/09,DOYLE V ICON, LLC,15,15"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")