import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<latitude>[-]?[0-8]?[0-9]\\.\\d+|[-]?90\\.0+?)(?<delimeter>.)(?<longitude>[-]?1[0-7][0-9]\\.\\d+|[-]?[0-9]?[0-9]\\.\\d+|[-]?180\\.0+?)$";
final String string = "-12.213213;-1.21321";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}